FAQ  •  Register  •  Login

Key Performance Indicators?

<<

jimbomahoney

Master

Posts: 60

Joined: Wed Feb 27, 2019 11:21 am

Post Wed Apr 17, 2019 2:20 pm

Key Performance Indicators?

I'm wondering what the key performance indicators are for the Helios and whether or not the automated tuning protocol is adequate (I would assume that it is, but I like tinkering / understanding / increasing performance).

As a proverbial tinkerer / optimiser, I've been intrigued that sometimes, my Tb/Tm DCs can be higher before the tune than after. Assuming that Tb/Tm DCs are a key performance indicator (KPI), it would seem that the subsequent tuning procedure "de-optimised" the system.

I'm aware however that it's a balancing act between the oxidation levels (lower = better?, generally indicated by La 139 -> 155?) and the Tb/Tm DCs and therefore the tuning protocol may have changed other settings that actually overall improved the performance of the system, despite the Tb/Tm DCs going down.

I'm also aware of the method to calculate the CV of the EQ beads (using plotviewer to plot 151/153 and then cluster the beads to get the CV. Lower = better and should be <12%).

I'm also plotting most / all of the data that the tuning history results contain.

So with all of that said, I guess my questions are:

1) How do more experienced users judge the performance of their Helios?
2) Do you find the automated tuning protocol adequate / optimal?
3) Do you find the automated tuning protocol can vary naturally in the settings it chooses? e.g. two identical runs where nothing has changed can result in slightly different settings.
<<

mleipold

Guru

Posts: 1778

Joined: Fri Nov 01, 2013 5:30 pm

Location: Stanford HIMC, CA, USA

Post Wed Apr 17, 2019 3:01 pm

Re: Key Performance Indicators?

Hi James,

I miss Manual Tuning. In fact, I've been arguing with Fluidigm for almost 4 years now about the *lack* of the ability to manually tune Helios instruments. I have confirmed with them that there is *no way* to manually tune using the current Helios software. And frankly, they don't seem interested in updating the software to do it.


It's not uncommon for the Automated Tuning to change things a bit, even if you change nothing and run Tuning multiple times. In a lot of cases, the Tb/Tm values will change from before Tuning, but in some cases that's because the "Gd155" (La139+O16) oxide ratio was >3% of the Tb159 signal and your eye can't necessarily tell.


I would say that I find the Automated Tuning *adequate*. There are definitely times when it fails due to %RSD or something like that where we're content with it and would like to move on. I have also confirmed with them that there's *no* way to force-apply a "failed" Tuning, even in Service Mode: if it fails, it fails, and all you can do is rerun it.


But there are definitely some problems with it. For one, there's a notable disagreement between the Oxide calculated during the Gases/Current adjustment, and the Oxide reported as part of the QC Report (and which can trigger a Failed Tuning). On my instruments, the QC Oxide is *always* higher than the Adjustment Oxide, and it's frankly infuriating when the Adjustment Oxide will be, say, 2.5% oxide and the QC Oxide will be 3.1% oxide, which triggers a Failed Tuning. Fluidigm knows about this issue, but again has failed to do anything about it for almost 4 years.

Additionally, the Gases/Current adjustment has some issues. I understand that it's trying to optimize 3 things at once (NG, MG, and Current), which is difficult. But occasionally it gets locked into a local minimum rather than global minimum, and you wind up with, say, 1% oxide. In theory this is fine, but in practice this causes you to lose 10-15% of your Tb/Tm value. This is something that happens a lot when we get near the end of our Skimmer-Reducer cone lifetime: for reasons I don't understand (and Fluidigm either doesn't understand, or won't explain to me), as the skimmer gets older, the Tb/Tm signal drops, but that's largely due to the Gases/Current Optimization dropping to lower and lower Oxide ratio. In particularly, it will consistently go below 1%, and stay there even after an instrument cleaning. If I manually play around with the MG or Current setting in Control Panel, then I can get the Oxide higher, but then if I do the Automated Tuning again, the software "optimum" is again always below 1%.


Mike
<<

desireeBCRT

Participant

Posts: 10

Joined: Mon Jan 06, 2014 11:56 am

Post Mon Apr 22, 2019 5:51 pm

Re: Key Performance Indicators?

Hi James,

we find that our instrument is not automatically applying the last tuning results when we start it. We manually apply the last tuning result before we look at the tuning solution and start the tuning. In cases we forget to do so, we also often see higher Tb counts before the tuning than after the tuning. We don't know to which setting our instrument is going back to, though. I don't know if there is a default setting that it starts with?

Desiree

Return to Introduction to mass cytometry

Who is online

Users browsing this forum: No registered users and 1 guest