FAQ  •  Register  •  Login

Windows 10 upgrade and slow IMD processing

Forum rules
Please be polite and civil. We know that troubleshooting is vexing...
<<

richardellis

Participant

Posts: 15

Joined: Mon Dec 09, 2013 11:03 am

Post Wed Apr 21, 2021 10:21 am

Windows 10 upgrade and slow IMD processing

Dear all, I know many of you were previously forced by your IT depts to update your systems for Windows 10 compliance - we only just got around to this. We have found that processing is significantly slower at the end of a run on the new PCs (the unmarked slimline ones) than either the Fluidigm custom-built PCs (in an Astec case) or the HPZ840 which we had on Windows 7. Those of you who upgraded already, did you have a similar experience and have you found a way to resolve it?

As an example, at the end of a run, the typical processing time at the end of runs (while event number is still increasing but sample stopped acquiring) is now around:
3 minutes for a 50,000 event EQ bead file run for 5 minutes
10 minutes for a small single tube of cells (300,000 to 500,000 events)

And we had our first ever API buffer overflow whilst in Hyperion mode, which may or may not be related. That is not to say these were common in Helios mode previously either, they weren't! Notes on setup:
- We don't really run much other software except maybe a web browser and Word while acquisition takes place.
- From the Windows process monitor it isn't obvious what is slowing the processing (cache file? CPU?) except maybe that not all cores on the CPU are in use.
- These are not dirty samples with lots of background (I know that slows things down), it happens even with just beads (as above).
- Settings are on defaults, as installed (software is 7.0.8493)
- In Helios software, IMD buffer size is 1,048,576 bytes and Real time is 16,777,216 (again, as installed)

If you found any solution to this I'd be grateful to hear as we are nervous about running much longer e.g. barcoded samples in this way.
Guy's Hospital flow core, London
<<

mleipold

Guru

Posts: 5448

Joined: Fri Nov 01, 2013 5:30 pm

Location: Stanford HIMC, CA, USA

Post Wed Apr 21, 2021 3:05 pm

Re: Windows 10 upgrade and slow IMD processing

Hi Richard,

We haven't really seen this issue with our Win10 upgrades in Dec 2019.

For example, using On-the-fly processing with a 37 channel panel and acquiring 250K in ~20min, the file processing finishes in 15-20sec after the termination of acquisition. In other words, we reach 250K, it processes another 15-20sec, and then we get the FCS file and pop-up saying acquisition is completed.


Our third instrument did have a number of API buffer overflow issues, and I believe we had to replace the tower to make them go away. So, it's possible that your tower is a lemon.


Mike
<<

rgrenfell

Contributor

Posts: 29

Joined: Thu Aug 27, 2015 12:31 pm

Post Fri Apr 23, 2021 9:21 am

Re: Windows 10 upgrade and slow IMD processing

Hi Richard (& everyone else)

We've had Win10 running on our 2 IMC's for a while now. I think we get slightly fewer API buffer overruns now. Probably more due to consciously restarting the the PC's regularly & after longer runs

Had the pc on the Helios replace a couple of months ago. I've not seen a difference in the processing time. We were seeing 5 mins for 500k events, sometimes more before and I'm still seeing that sort of timescale for processing now. I've not noticed any change in processing time at all. (gives me long enough to rinse the sample line after the sample has stopped while its processing)

Our PCs are the slimline unmarked ones on all 3 bits of kit now

Richard
<<

richardellis

Participant

Posts: 15

Joined: Mon Dec 09, 2013 11:03 am

Post Mon Apr 26, 2021 12:06 pm

Re: Windows 10 upgrade and slow IMD processing

Thanks both, it really sounds like there is something wrong then, it did seem like it would be a massive step backwards! I'm disappointed as both our systems are affected by this, I've been hoping that there was an issue with the setup rather than needing to replace them.
Guy's Hospital flow core, London

Return to CyTOF troubleshooting

Who is online

Users browsing this forum: Bing [Bot] and 1 guest